CRAN Package Check Results for Package MetaIntegrator

Last updated on 2019-02-22 00:01:17 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 2.0.0 10.05 151.47 161.52 OK
r-devel-linux-x86_64-debian-gcc 2.0.0 9.09 232.66 241.75 OK
r-devel-linux-x86_64-fedora-clang 2.0.0 174.21 NOTE
r-devel-linux-x86_64-fedora-gcc 2.0.0 167.27 NOTE
r-devel-windows-ix86+x86_64 2.0.0 24.00 194.00 218.00 OK
r-patched-linux-x86_64 2.0.0 7.86 165.80 173.66 OK
r-patched-solaris-x86 2.0.0 205.30 NOTE
r-release-linux-x86_64 2.0.0 OK
r-release-windows-ix86+x86_64 2.0.0 17.00 185.00 202.00 OK
r-release-osx-x86_64 2.0.0 WARN
r-oldrel-windows-ix86+x86_64 2.0.0 12.00 167.00 179.00 OK
r-oldrel-osx-x86_64 2.0.0 WARN

Check Details

Version: 2.0.0
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘DT’ ‘GEOmetadb’ ‘RMySQL’ ‘RSQLite’ ‘gplots’ ‘pheatmap’ ‘readr’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 2.0.0
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘BiocStyle’
Flavors: r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 2.0.0
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 26-27 (MetaIntegrator.Rmd)
    Error: processing vignette 'MetaIntegrator.Rmd' failed with diagnostics:
    there is no package called 'BiocStyle'
    Execution halted
Flavors: r-release-osx-x86_64, r-oldrel-osx-x86_64