CRAN Package Check Results for Package TSPred

Last updated on 2024-06-13 11:48:32 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 5.1 8.11 98.19 106.30 OK
r-devel-linux-x86_64-debian-gcc 5.1 0.55 1.77 2.32 ERROR
r-devel-linux-x86_64-fedora-clang 5.1 130.95 NOTE
r-devel-linux-x86_64-fedora-gcc 5.1 126.01 NOTE
r-devel-windows-x86_64 5.1 10.00 107.00 117.00 OK
r-patched-linux-x86_64 5.1 19.21 93.19 112.40 OK
r-release-linux-x86_64 5.1 8.71 94.77 103.48 OK
r-release-macos-arm64 5.1 38.00 OK
r-release-macos-x86_64 5.1 53.00 OK
r-release-windows-x86_64 5.1 10.00 211.00 221.00 OK
r-oldrel-macos-arm64 5.1 42.00 OK
r-oldrel-macos-x86_64 5.1 57.00 OK
r-oldrel-windows-x86_64 5.1 13.00 300.00 313.00 OK

Check Details

Version: 5.1
Check: package dependencies
Result: ERROR Packages required but not available: 'forecast', 'dplyr', 'keras', 'tfdatasets' See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’ manual. Flavor: r-devel-linux-x86_64-debian-gcc

Version: 5.1
Check: dependencies in R code
Result: NOTE Namespaces in Imports field not imported from: ‘EMD’ ‘vars’ All declared Imports should be used. Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc