CRAN Package Check Results for Package bnclassify

Last updated on 2019-10-21 17:48:53 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.4.2 123.93 103.09 227.02 OK
r-devel-linux-x86_64-debian-gcc 0.4.2 75.19 72.53 147.72 OK
r-devel-linux-x86_64-fedora-clang 0.4.2 269.63 WARN
r-devel-linux-x86_64-fedora-gcc 0.4.2 253.05 OK
r-devel-windows-ix86+x86_64 0.4.2 263.00 178.00 441.00 OK
r-patched-linux-x86_64 0.4.2 92.58 98.79 191.37 OK
r-patched-solaris-x86 0.4.2 228.70 OK
r-release-linux-x86_64 0.4.2 93.54 100.98 194.52 OK
r-release-windows-ix86+x86_64 0.4.2 305.00 238.00 543.00 OK
r-release-osx-x86_64 0.4.2 WARN
r-oldrel-windows-ix86+x86_64 0.4.2 184.00 189.00 373.00 OK
r-oldrel-osx-x86_64 0.4.2 NOTE

Check Details

Version: 0.4.2
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     basic-probs.cpp:7:13: warning: 'bind2nd<std::__1::plus<double>, double>' is deprecated [-Wdeprecated-declarations]
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 0.4.2
Check: installed package size
Result: NOTE
     installed size is 7.1Mb
     sub-directories of 1Mb or more:
     libs 6.2Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 0.4.2
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     'graph', 'gRain', 'gRbase', 'Rgraphviz'
Flavor: r-release-osx-x86_64

Version: 0.4.2
Check: Rd cross-references
Result: NOTE
    Package unavailable to check Rd xrefs: ‘gRain’
Flavor: r-release-osx-x86_64

Version: 0.4.2
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘methods.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    --- finished re-building ‘methods.Rmd’
    
    --- re-building ‘overview.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    --- finished re-building ‘overview.Rmd’
    
    --- re-building ‘usage.rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 121-122 (usage.rmd)
    Error: processing vignette 'usage.rmd' failed with diagnostics:
    Package graph needed
    --- failed re-building ‘usage.rmd’
    
    SUMMARY: processing the following file failed:
     ‘usage.rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-osx-x86_64